Jason Meridth

I am a continuously learning senior full stack SDE/SRE trying to not let best be the enemy of better.

Buy me a coffeeBuy me a coffee

Code snippets in blog entries, HELP!

09 Sep 2007 » »

UPDATE: Problem solved.  Had to uninstall VSPaste plug-in first and uninstall the Code Snippet plug-in, restart, and then re-install.  Fun fun.  Newbie problem

To all bloggers out there that post code into their blog and also use Windows Live Writer, HELP!

I was currently using VSPaste plug-in.  It looks great when writing the entry in the Live Writer; even the web preview looks great:

image

Notice the pretty colors.  When uploaded, the code is just black text with no styles applied.  A colleague spoke with Community Server and they suggested removing any custom CSS that may overwrite what styles the VSPaste plug-in is using. 

I saw the Code Snippet Plug-in and downloaded it, but no matter how much I try, I can’t get it to show up in my list of plug-ins (Tools-> Options-> Plug-ins):

image

Any suggestions??

Yes, I know, I’m a developer, custom CSS is always an option too. I’d like to try tools that are out there first, please. :)

Comments

joeyDotNet: Hey Jason, I’ve tried out many of them and the best one I’ve found so far (if you’re a WLW user as I am), is this code snippet plug-in for WLW: http://gallery.live.com/liveItemDetail.aspx?li=d4409446-af7f-42ec-aa20-78aa5bac4748&bt;=9&pl;=8

Jason Meridth: Sweet. I figured as much, but when I run the MSI it installs, but I can’t find the plugin in my plugins window in WLW. Any suggestions? Am I having a newbie brain-fart? This is used in WLW and not VS 2005/2008, right?